Wednesday, 29 February 2012

Marantz SR7500 repair


This receiver had 3 different faults, which lead me to think it had been used as spare parts! A quick resistance check of the primary & secondary windings of the mains transformer and no open or short circuits (thank goodness).




http://www.hometheaterhifi.com/volume_12_4/marantz-sr7500-receiver-10-2005.html




Upon opening it up and removing sub-boards - there were the tell tale touch up solder on certain points  - quite obvious it had been looked it.

This unit had been manufactured late 2005, as stamped inside the case. It mostly consisted of through hole (leaded) components on single sided PCBs.

The DSP/CPU board however was a double sided PCB with mostly surface mount components.

image taken from http://www.nubert-forum.de/nuforum/viewtopic.php?f=10&t=16013

What really shocked me was that the manufactured build quality of this unit was far from the best I have seen. Solder joints looked dull (cold), especially on the jumper links of the single sided boards. Spent some time re-soldering these joints.

Power on issue


The power on issue was caused by a low value resistor (essentially used as a fuse - in red). I initially thought it was a faulty bridge rectifier (in green) since the resistor measured OK when not powered  up. There was also no output from the bridge rectifier. After replacing the bridge rectifier I knew straight away it was the resistor. It must have been  going high impedance when current was being drawn from it. This supplies the remainder of the low voltage rails necessary to power up the CPU/DSP section and display.



After addressing this - I was relieved to see the display and unit powered up.However it was now going into Protection mode.

Standby board

This unit uses a standby board. How this works.
1. When the main ON/OFF switch is initially turned on, this powers on a standby transformer. This is a step down transformer that provides a +5V rail to power up the main CPU.
2. A mains relay that is controlled by the CPU. This switches in the primary side of the mains transformer.
3. The CPU performs, some checks namely low voltage line checks and amplifier checks namely:
  • Over current
  • Offset voltage
  • Over temperature (high heat sink temperature >80C, amplifier running at to much load continuously)
Any one of these three conditions will cause the unit to go into protection mode.

Repairing an amplifier channel

The unit also had a blown amplifier channel. This was easy to determine by checking for short circuits across the output driving transistors. The worry with a blown channel is that it is likely to have also taken out a number of other components. This proved to be the case.
Firstly I removed both transistors from the blown channel, as it was short circuiting the audio bus voltage. I did this so I could power up the amplifier to ascertain which channels worked and which did not.

After powering the unit up and driving output to speakers, I found that the front left, front right channels and surround left and right channels were operating. I had no center, sub woofer and rear surround left and right. My initial thought was it had to be something common that affected these channels.
AV receivers have a test tone mode that you can put through each channel. I did this while probing an oscilloscope onto the channel outputs of the Electronic Volume Control IC's (Toshiba TC9482). Sure enough had the test signal coming into the Volume control IC inputs, but no output! Faulty TC9482 (circled in red below).

 image taken from http://www.nubert-forum.de/nuforum/viewtopic.php?f=10&t=16013

These seem difficult to get as they are typically only used in audio equipment.

Going back to the blown amplifier channel - rear surround left.

Using a multimeter set to measure resistance I checked a number of components and found along with the 2 output transistors (big red circles) diodes, and zener diodes had also gone short circuit, the resistor had gone high impedance.


The audio output transistors are difficult to get. Sanken SAP17N , and SAP17P, 5 terminal darlington audio output transistors.

Protection Mode


After replacing these components in the amplifier the unit was still going into protection mode.


As soon as the CPU detects one of the three conditions for protection mode the CPU switches off the main relay and thus the primary power side of the main power transformer. 
There were still problems in the rear surround channel circuit, as I had the amplifier running when I had removed the output transistors.

The next problem was how to run the unit without it switching OFF? Solder a wire across the main relay contacts on the standby board, so the main transformer stays ON!
Now I could measure some voltages without the entire unit powering OFF into protect mode.

I found a -47V dc offset at the output, and virtually -47Vdc on both ends of the AC coupling capacitor (circled in red).The output of the NJM2068 op-amp (in blue) was -11Vdc. This is what was clearly driving the output negative. It looks like when the output transistor pair blew it also took out the capacitor and op-amp input (due to over voltage). 


I'm not sure where to buy NJM2068 operational amplifiers (op-amp) from. Element14 (formerly Farnell) my local go to does not carry them.
I decided on replacing the '2068 with a On-Semi MC33078. Similar specifications on paper, and cheap enough in 1 off quantities under $2 for an audio op-amp.


Replaced both capacitor and op-amp, and removed the wire link from the mains relay on standby board. Presto - unit does not go into protection mode.
Tested each individual channel out driving it with sound - and all appears well and good. I will be keeping it even though it does not have HDMI.


Note: For new players the author does not recommend attempting to repair  mains powered equipment.Mains equipment requires care, attention and are at lethal voltages.

Disclaimer: The information contained in this post is for educational purposes only. The author accepts no responsibility for any damages or harm that may arise.